IApplicationBuilder does not contain a definition for 'UseSpa'

  1. bkrslmz
    2
    307
    22.06.2020 11:07:00

    UseSpa(spa=> kod satırında IApplicationBuilder does not contain a definition for 'UseSpa' hatasını alıyorum

     .Configure(
              app => app
                  .UseSpa(spa =>
                  {
    var scopeFactory = spa.ApplicationBuilder.ApplicationServices.GetRequiredService<IServiceScopeFactory>();
                      using (var scope = scopeFactory.CreateScope())
                      {
                          var dbInitializer = scope.ServiceProvider.GetService<IDbInitializerService>();
                          dbInitializer.Initialize();
                          dbInitializer.SeedData();
                      }
    
                      spa.ApplicationBuilder.UseStaticFiles();
    
                      spa.ApplicationBuilder.UseSpaStaticFiles();
                      spa.Options.SourcePath = "wwwroot";
    
                  })
    
                  )
    

    çözüm arıyorum sorun için

    asp.net-core asp.net-core-mvc .net-core 4 ay önce 279 Görüntüleme
    • omrbayraktar Microsoft.AspNetCore.SpaServices.Extensions nuget package manager dan yüklenen paketlerden yüklü olduğundan emin olun

    • Yorum Ekleyin

( 1 ) Cevap

  1. koraydrk
    2
    2699
    22.06.2020 11:38:00

    MErhabalar, Çözüm için ;

    Nuget Package Manager dan ;

    Microsoft.AspNetCore.SpaServices.Extensions
    

    paketini yüklemeniz yeterli, sorun çözülecektir

Cevabınız